CONT.SE contar valores com condição

Utilize a função CONT.SE do Microsoft Excel da categoria estatística para contar valores com condição. Essa função calcula o número de vezes que um critério se repete no intervalo.

Sintaxe da Função

Abaixo vamos analisar a sintaxe da função CONT.SE, lembrando que toda função tem uma sintaxe, que é um conjunto de informações organizadas de maneira estrutural, ou seja, um conjunto de regras, que consiste no nome da função e seus argumentos.

Podemos inserir uma função no Excel utilizando o assistente de função que antecede a barra de fórmulas o ícone fx e seguir os parâmetros do assistente, podemos optar em digitar a função que automaticamente aparece o assistente embaixo ou ainda na barra Fórmulas e explorar as opções do grupo Biblioteca de funções.

Sintaxe (conjunto de regras) :

=CONT.SE(INTERVALO;CRITÉRIO)

Intervalo: É o intervalo de células no qual se deseja contar células que não estão em branco.

Critério: É a condição, na forma de um número, expressão ou texto, que define quais células serão contadas.

Observação: Você pode inserir endereço de célula que tenha o critério ou digitar o texto, caso opte pela digitação a informação precisa ser escrita entre aspas “critério”.

Exemplo prático

Vamos supor que você tenha um intervalo de células com uma relação de cidades e você precisa saber quantas vezes uma determinada cidade aparece no intervalo, utilize a função CONT.SE para chegar nesse resultado.

O intervalo é a lista de células que iremos procurar o critério. Vamos usar como exemplo uma lista de cidades que se repetem, desse intervalo queremos descobrir quantas vezes a cidade “São Paulo” aparece, então “São Paulo” será o nosso critério.

ABC
1ClientesCidadesValor
2AnaSão Paulo R$       184,00
3PauloOsasco R$       175,00
4JoãoBarueri R$       201,00
5FernandoJandira R$       162,00
6AndersonCotia R$       234,00
7MilenaItapevi R$       244,00
8CarlaSão Paulo R$       184,00
9DenisOsasco R$       181,00
10RodrigoBarueri R$       182,00
11PalomaJandira R$       204,00
12FelipeCotia R$       130,00
13AluanaItapevi R$       154,00
14CláudiaSão Paulo R$       188,00
15MauroOsasco R$       140,00
16JonasBarueri R$       115,00
17AnaJandira R$       148,00
18BiancaCotia R$       117,00
19VagnerItapevi R$       113,00
20MariaSão Paulo R$       221,00

Para descobrir quantos clientes na cidade de São Paulo utilize a função da seguinte maneira:

=CONT.SE(B1;B20;”São Paulo”)

O resultado será igual à 4

Importante

Preste muita atenção quando for digitar o critério, ele precisa ser escrito entre aspas duplas, caso escreva de maneira diferente que aparece no intervalo, ou sem querer acabar digitando um espaço depois da palavra(esse é um erro comum tanto na palavra pesquisada quando no preenchimento da base de dados), o Microsoft Excel entende que é uma informação nova, já que o “espaço” ocupa espaço na memória e existe diferença entre caracteres digitados.

lembrando que pode inserir o critério em uma célula ao invés de escrever o critério entre aspas duplas, nesse caso, utilize o endereço da célula.

Veja o exemplo abaixo, agora utilizado endereço de célula ao invés de digitar o critério entre aspas:

ABCDEF
1ClientesCidadesValorQtd. Clientes
2AnaSão Paulo R$       150,00São Paulo = CONT.SE (B1: B10, E 2)
3PauloOsasco R$       112,00
4JoãoBarueri R$       232,00
5FernandoJandira R$       186,00
6AndersonCotia R$       220,00
7MilenaItapevi R$       185,00
8CarlaSão Paulo R$       101,00
9DenisOsasco R$       208,00
10RodrigoBarueri R$       140,00

Como o intervalo foi menor, das células B1:B10, o resultado será 2. A palavra São Paulo está digitada da mesma maneira que se encontra na base de dados.

Repare que a função cont.se trabalha com a contagem de valores, quantas vezes determinada palavra aparece  no intervalo.

Caso você queira realizar a soma de valores à partir de um critério, é necessário utilizar a função SOMASE. No canal do Youtube Novos Resultados Excel tem vídeo sobre esse assunto.

Acompanhe o vídeo do nosso canal no Youtube para melhorar a compreensão de como o Excel conta valores com condição, ou seja, como ele conta valores repetidos através da função CONT.SE.

Assista o vídeo abaixo:

Segue o link para fazer o download a planilha do vídeo:

CONT.SE

Canal no Youtube: Novos Resultados Excel

#Contar excel valores repetidos #Excel contar valores com condição #contar excel valores #excel contar valores iguais

 

Faça o download deste post inserindo seu e-mail abaixo

Não se preocupe, não fazemos spam.
Esta entrada foi publicada em Excel e marcada com a tag , , , , , , , , , , . Adicione o link permanente aos seus favoritos.